Monthly Archives: January 2015

What’s the Word on Yosemite?

OS X Yosemite

“Can I update to Yosemite?” Yes! It’s mostly all clear unless you use one particular piece of software: Parallels. If you are running anything lower than Parallels version 9, it will not work with Yosemite. Otherwise, a very small percentage of people have experienced one or more of the following issues, documented by Tech Republic’s… Read more »